What devices are compatible with pixsee app?
pixsee app is compatible with most iOS and Android devices.

Compatibility Requirements:
For Android - software version 8.0 or later
For iOS - software version 13.0 or later
last updated: 2022/05/22
This article is helpful?
Thanks for your feedback!
Please provide your thoughts to help us do better
related articles
We use cookies to enhance your viewing experience. By continuing to browse, you are agreeing to our use of cookies. read more